Archive

Posts Tagged ‘hotfix’

OpenSolaris FIX: Server refused to allocate pty (SSH)

May 11th, 2010 5 comments

Just upgraded a friends OpenSolaris boxen to SNV_134 (latest available from the OpenSolaris dev repository) and after rebooting we realised we couldn’t SSH into it.

Server refused to allocate pty

DOH! This is caused by a known bug that has been around for a few builds now.

You’ll need to modify /etc/minor_perm and add the following to the bottom of the file.

clone:ptmx 0666 root sys

And what happens if your terminals don’t accept keyboard input? You could drop back into the shell *or* be lazy like me, find gText editor in your Accessories, add it to the panel and change the properties to run it as a privileged user:

pfexec gedit %U

Then run the file, open the /etc/minor_perm file, save and reboot. Make sure you change back the shortcut path 🙂

{lang: 'en-GB'}
Share

FIX: ‘The Microsoft.Jet.OLEDB.4.0 provider is not registered on the local machine.’ Message for .NET Applications

April 2nd, 2009 4 comments

Came across a post on DeveloperFusion today that resonated the same issue we had at work a few days earlier involving JET (no not the band) accessing an Access database in .NET code on Windows x64.

If you find you get a nasty:

The Microsoft.Jet.OLEDB.4.0 provider is not registered on the local machine.

When you run your .NET Application – and I know this – on your x64 box, its because Microsoft does not support JET on 64bit versions of Windows outside of Windows 2003.

So, what to do? Simple, you need to make sure that the assembly is written targeting ‘x86’ rather than ‘Any CPU’ or ‘x64’ in the Configuration Manager, rebuild the assemblies and you should be good to go 🙂

{lang: 'en-GB'}
Share

Windows Vista SP2 RC and Windows Server 2008 SP2 RC Available to General Public

March 4th, 2009 1 comment